Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3620 closed defect (fixed)

"Block element" doesn't consider $genericblock when generating filters

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29335437

Description

How to reproduce

  1. Add filter @@||google.com^$genericblock
  2. Go to https://google.com/
  3. Click ABP toolbar icon
  4. Choose "Block element"
  5. Click on the Google logo
  6. Add the suggested filters
  7. Reload the page

Observed behaviour

Following filters are suggested (and added):

||google.com/images/branding/googlelogo/2x/googlelogo_color_272x92dp.png
||google.com/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png

After reloading the page, the logo however keeps showing. That is because due to the $genericblock exception rule added earlier, blocking filters without $domain option are ignored.

Expected behaviour

When a $genericblock exception rule is in effect, the "Block element" dialog should suggest only domain specific filters, so that the element actually gets blocked. For the Google logo this would be following filters:

||google.com/images/branding/googlelogo/2x/googlelogo_color_272x92dp.png$domain=google.com
||google.com/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png$domain=google.com

Change History (5)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next

comment:4 Changed 4 years ago by sebastian

  • Summary changed from "Block element" doesn't consider $genericblock to "Block element" doesn't consider $genericblock when generating filters

comment:5 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Behaviour now matches what is described in Expected behaviour (domain is suggested at the end of the filter).

ABP 1.10.2.1558
Chrome 35 / 47 / Windows 7 x86
Chrome 48 / Ubuntu 14.04 x64
Opera 25 / 35 / Windows 7 x86
Opera 35 / Ubuntu 14.04 x64
Safari 6 (OS X 10.8) / Safari 8 (OS X 10.10) / Safari 9 (OS X 10.11)

Last edited 4 years ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.