Opened 4 years ago

Closed 4 years ago

#3626 closed defect (fixed)

Ghost mode tab's closing cross button is too close to ghost control buttons

Reported by: michal.kuric Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario, scheer Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

iOS (all versions)
iPhone (all versions)
ABB 1.3.0-qa, (core 1.3.6-qa) (Build 801)
no filters enabled (doesn't affect)

How to reproduce

  1. Open ABB
  2. Select Ghost mode via tab icon in a lower right corner
  3. Open as many new tabs they will fill one page of listing
  4. Scroll down to the last tab

Observed behaviour

Closing button "x" is so close to the ghost mode control buttons that it's uncomfortable to close it.

Expected behaviour

Closing button "x" should be place at more UX friendly place.

Attachments (2)

Screen Shot 2016-02-03 at 4.15.33 PM.png (25.1 KB) - added by michal.kuric 4 years ago.
bug screenshot
screen_shot_2016-02-03_at_17.22.09_480.png (29.8 KB) - added by jand 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by michal.kuric

bug screenshot

comment:1 Changed 4 years ago by jand

  • Priority changed from Unknown to P1
  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Batch modify: added Adblock-Browser-for-iOS-next milestone.

comment:3 Changed 4 years ago by scheer

  • Cc scheer added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Would it be possible to have some information on the changed design and intended new behaviour? As in, how should the Closing button now react in said situation?

comment:4 Changed 4 years ago by jand

Original tab view with several open tabs with inaccessible close button of the last tab:
https://issues.adblockplus.org/raw-attachment/ticket/3626/Screen%20Shot%202016-02-03%20at%204.15.33%20PM.png

The solution was to allow to move the last tab above add tab banner:
https://issues.adblockplus.org/raw-attachment/ticket/3626/screen_shot_2016-02-03_at_17.22.09_480.png

comment:5 Changed 4 years ago by mario

  • Cc salsita removed

comment:6 Changed 4 years ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Tester changed from Unknown to Scheer
  • Verified working set
  • The user is now able to slide the bottom most tab in Ghostery mode above the '+' button so that the user is able to delete the tab.

ABB 1.3.0-qa (824)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.