Opened 4 years ago

Closed 4 years ago

#3627 closed defect (rejected)

Ghost mode tab is reopened after app kill/crash

Reported by: michal.kuric Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario, salsita Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

iOS (all versions)
iPhone (all versions)
ABB 1.3.0-qa, (core 1.3.6-qa) (Build 801)
no filters enabled (doesn't affect)

How to reproduce

  1. Open ABB
  2. Open new page in ghost mode
  3. Open iOS task view (by double-clicking home button)
  4. Kill ABB
  5. Open ABB again

Observed behaviour

Ghost mode tab is reloaded after app was killed (or it crashed).

Expected behaviour

This behavior was not described in the original task https://issues.adblockplus.org/ticket/3408

Change History (1)

comment:1 Changed 4 years ago by mario

  • Resolution set to rejected
  • Status changed from new to closed

This is intended behaviour. Thus rejecting it as a bug. However we'll internally discuss whether to add this as a feature later in order to introduce more consistency regarding "removing/forgetting data".

Note: See TracTickets for help on using tickets.