Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3645 closed defect (fixed)

Tab indicator is 0 for a few seconds after a fresh installation

Reported by: mario Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

iPhone 5, iPhone 6
iOS 9.2
ABB 1.3.0-QA

How to reproduce

  1. Remove ABB from the device if it is still installed
  2. Install ABB 1.3.0-QA
  3. Open ABB and skip the first run slides

Observed behaviour

After the first run slides are closed, the tab indicator at the bottom right of the screen displays "0". After a few seconds it automatically switches to "1".

Expected behaviour

After the first run slides are closed, the tab indicator at the bottom right of the screen should display "1".

Change History (9)

comment:1 Changed 4 years ago by mario

  • Keywords salsita added
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:4 Changed 4 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer
  • After the first run slides are closed, the tab indicator at the bottom right of the screen displays "0". After a few seconds it automatically switches to "1".

ABB 1.3.0-qa (836)
iPhone 6 Plus - iOS 9.2.1

comment:5 Changed 4 years ago by mario

  • Milestone Adblock-Browser-for-iOS-next deleted
  • Resolution set to fixed
  • Status changed from reopened to closed

Removed the milestone and closed the issue. This change isn't supposed to land in 1.3.0.

comment:6 Changed 4 years ago by jand

@mario: I cherry picked this fix from develop to current release. Should I remove it?

comment:7 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

@jand, if it's already in, I'm fine with keeping it for the current release. Added the milestone. :)
Please let scheer and me know as soon as a build is available containing this issue.

comment:8 Changed 4 years ago by jand

Build 1.3.0-qa (837) should contain that fix.

comment:9 Changed 4 years ago by scheer

  • Verified working set
  • After the first run slides are closed, the tab indicator at the bottom right of the screen displays "1" without a delay of a few seconds.

ABB 1.3.0-qa (837)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.