Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#3647 closed defect (fixed)

Website preview of an empty tab doesn't work properly

Reported by: mario Assignee: jand
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: pavelz, jand Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

iPhone 5, iPhone 6
iOS 9.2
ABB 1.3.0-QA

How to reproduce

  1. Open ABB
  2. Open the tab view and close all opened tabs (while closing the last tab a new, empty tab will be created)

Observed behaviour

The website preview of the remaining empty tab is too small as displayed in this screenshot.
(Note that this only happens if all tabs are closed. Manually adding new tabs display the website preview correctly)

Expected behaviour

The website preview of the remaining empty tab should be in its default width and height as displayed in this screenshot.

Attachments (2)

ABB_tab_1.PNG (35.7 KB) - added by mario 4 years ago.
ABB_tab_2.PNG (36.4 KB) - added by mario 4 years ago.

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by mario

Changed 4 years ago by mario

comment:1 Changed 4 years ago by mario

  • Description modified (diff)

comment:2 Changed 4 years ago by mario

  • Keywords salsita added
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 4 years ago by jand

I cannot reproduce this issue. It might have been fixed in the current develop. I had to change web view background.

comment:4 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

I understand the comment as "closeable to be tested"

comment:5 Changed 3 years ago by pavelz

  • Milestone set to Adblock-Browser-for-iOS-1.3.0

comment:6 Changed 3 years ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer
  • The website preview of the remaining empty tab still shows as a smaller icon than it should be.

ABB 1.3.0-qa (852)
iPhone 6 Plus - iOS 9.2.1

comment:7 Changed 3 years ago by mario

  • Cc pavelz added

comment:8 Changed 3 years ago by pavelz

  • Cc jand added

This will have to wait for Jan to get back from vacation on Monday

comment:9 Changed 3 years ago by pavelz

  • Owner set to jand

comment:10 Changed 3 years ago by jand

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 3 years ago by scheer

  • Verified working set
  • The website preview of the remaining empty tab is now in it's default width.

ABB 1.3.0-qa (863)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.