Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#367 closed defect (incomplete)

ABP options page cannot be opened correctly by browsers' "last opened pages" function

Reported by: philll Assignee: sebastian
Priority: P2 Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: yes
Review URL(s):

Description

Environment

Chrome 34 / Safari 7
ABP 1.7.4
Browser setting "Open last viewed pages at startup" enabled

How to reproduce

  1. Right click the ABP icon
  2. Click "Options"
  3. Close the browser
  4. Reopen the browser

Observed behaviour

Safari displays "Safari can’t open the page", Chrome loads the options page without images.

Taken from http://99tests.com/challenges/55/challengebugs/5791

Expected behaviour

The options page should be displayed correctly.

Change History (4)

comment:1 Changed 6 years ago by sebastian

In Safari the extension ID (part of the URL) is randomly generated on every startup. So when restoring the options page, its URL has changed. That is a Safari issue, we can't do much about.

I can't reproduce any unexpected behavior on Chrome. The options page including its images loads correctly, when I restart Chrome. And the bug reported on 99tests you referred to, also doesn't mention any issues on Chrome.

Last edited 6 years ago by sebastian (previous) (diff)

comment:2 Changed 6 years ago by sebastian

  • Owner set to sebastian
  • Status changed from new to assigned

comment:3 Changed 6 years ago by sebastian

  • Resolution set to invalid
  • Status changed from assigned to closed

comment:4 Changed 6 years ago by philll

  • Verified working set

Hm, can't reproduce this any longer for Chrome 34.0.1847.131 m with ABP 1.7.4.1162

Note: See TracTickets for help on using tickets.