Opened 3 years ago

Closed 3 years ago

#3684 closed defect (worksforme)

Link to disable Acceptable Ads in first-run page is broken

Reported by: arthur Assignee:
Priority: P1 Milestone:
Module: Unknown Keywords:
Cc: sebastian, greiner, kzar Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

OS X Yosemite 11.10 Beta
Safari 9.0
Adblock Plus 1.10.2

How to reproduce

  1. Install Adblock Plus from https://adblockplus.org/
  2. Click on "disable" at "If you still want to block every ad you can disable this in a few seconds".

Observed behaviour

Nothing happens.

Expected behaviour

The options window should show up allowing to the user to opt out of Acceptable Ads.

Tested it with Safari 8.0.6 as well which is working for me.

Change History (6)

comment:1 Changed 3 years ago by greiner

  • Cc greiner added

I was unable to reproduce this issue with the following setups:

OSX 10.11 Beta
Safari 9.0
Adblock Plus 1.10.2

OSX 10.10.3
Safari 8.0.6
Adblock Plus 1.10.2

Note that there's already a ticket about Safari messing up the initialization of JavaScript after using the back-button (see #3535). Therefore I'd assume that this is the same issue.

comment:2 Changed 3 years ago by sebastian

  • Cc kzar added

comment:3 Changed 3 years ago by kzar

I'm also not able to reproduce this on OS X 10.11 El Capitan with Safari 9.0. Both for 1.10.2 and current tip of repo.

comment:4 Changed 3 years ago by kzar

Also not able to reproduce this on the test machine running OS X 10.11 El Capitan Beta and Safari 9.0 after installing the extension 1.10.2 from the store.

comment:5 Changed 3 years ago by arthur

Strange, will try it tomorrow again.

comment:6 Changed 3 years ago by arthur

  • Resolution set to worksforme
  • Status changed from new to closed

Working for me today as well.

Note: See TracTickets for help on using tickets.