Opened 4 years ago

Closed 4 years ago

Last modified 5 weeks ago

#3688 closed defect (fixed)

Whitelisting websites has no effect in ABP for iOS

Reported by: scheer Assignee:
Priority: P1 Milestone: Adblock-Plus-for-iOS-next
Module: Adblock-Plus-for-iOS/macOS Keywords: salsita
Cc: mario, jand Blocked By:
Blocking: Platform: iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://github.com/adblockplus/adblockplussafariios/pull/27

Description (last modified by mario)

The user should be able to enter a website into the Whitelisting section of ABP for iOS and then be able to access the entered website without any blocking restrictions. Currently, this is not the case and after entering a website into the Whitelist, the site is still blocked.

Environment

ABP 1.1.0 (201601281708)
iPhone 6 Plus - iOS 9.2.1

How to reproduce

  1. Select the 'Whitelisted Websites' option from ABP
  2. enter a website that you wish to whitelist
  3. Select the '+' symbol to add the site to the list.
  4. Open Safari and navigate to one of the whitelisted websites

Observed behaviour

The whitelisted website is still blocked by ABP

Expected behaviour

ABP should be deactivated for the whitelisted website.

Change History (16)

comment:1 Changed 4 years ago by scheer

  • Description modified (diff)

comment:2 Changed 4 years ago by mario

  • Priority changed from Unknown to P1
  • Ready set

comment:3 Changed 4 years ago by scheer

  • Description modified (diff)

comment:4 Changed 4 years ago by scheer

  • Summary changed from Whitelisting websites has no affect in ABP for iOS to Whitelisting websites has no effect in ABP for iOS

comment:5 Changed 4 years ago by jand

The problem is in the if-domain property in filter of content blocker. It matches domain exactly, e.g. domains www.bild.de and m.bild.de are not recognized as part of bild.de.

It is not possible to use regular expression in if-domain, but I found out that asterisk (*) can be use to match subdomains (e.g. *bild.de).

comment:6 Changed 4 years ago by mario

@jand, is there any difference in iOS handling wildcards after reloading the filter list? I'm asking because of this:

*If the user adds the whitelisted site, disables the extension via Safari's extension settings, waits for c.a 30 seconds and then re-enables the option via Safari's extension options, the site is then whitelisted.

This sounds like there's more to it than iOS' way of handling wildcards.

comment:7 Changed 4 years ago by mario

  • Cc jand added

comment:8 Changed 4 years ago by jand

@mario: The problem is caused by redirection. We need to implement wildcard approach.

Regarding 30s activation delay. I tried that, and managed to reproduce it. It seems to me that content block is not enabled at all. If you activate content blocker you need to stay 10s and more in settings, before rules are loaded (I cannot do anything about that, 50 000 of rules is simply too much for Safari). If you leave settings earlier, content blocker is not activated.

comment:9 Changed 4 years ago by mario

  • Description modified (diff)
  • Keywords salsita added

I've removed the following part from the description:

*If the user adds the whitelisted site, disables the extension via Safari's extension settings, waits for c.a 30 seconds and then re-enables the option via Safari's extension options, the site is then whitelisted.

This effect is most likely caused by the filter list not being loaded by iOS. Thus this needs to be handled separately and doesn't directly affect this very issue.

comment:10 Changed 4 years ago by jand

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed

comment:11 Changed 4 years ago by jand

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 Changed 4 years ago by jand

  • Status changed from reopened to reviewing

comment:13 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplussafariios/rev/2e00f80d7100

comment:14 Changed 4 years ago by fhd

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:15 Changed 3 years ago by mario

  • Milestone set to Adblock-Plus-for-iOS-next

Batch-adjusted milestone for upcoming release of ABP for iOS.

comment:16 Changed 8 months ago by Thanos

Thanks for the nice post just follow here http://mahjongfreegames.online and share the latest mahjong free games online for the all players for more fun.

Version 0, edited 8 months ago by Thanos (next)
Note: See TracTickets for help on using tickets.