Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#369 closed defect (incomplete)

Adblock adds a huge load of CSS to Office365 Outlook mails

Reported by: TomNaessens Assignee: sebastian
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: mapx, greiner, fhd, philll Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

I'm working on Safari 7.0.3 on a Mavericks Macbook Air. On this machine, I use the webmail from Office365, located on https://outlook.office365.com/owa/.

How to reproduce

  1. Send an email from this platform to e.g. a gmail account
  2. Look at the source of the received email

Observed behaviour

This is the source of my received email: http://pastebin.com/hzM5fyqi. As you can see, there are over 3000 lines of CSS code added by Adblock. When disabling this adblock on that page, the mail is clean.

Expected behaviour

I expected that Adblock would not add CSS to my sent emails.

Change History (16)

comment:1 Changed 5 years ago by mapx

which ABP version are you using ?
what filter lists are enabled ?

comment:2 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 5 years ago by TomNaessens

Only EasyList is enabled. Version 1.7.4.1161. No idea if this helps but the other AdBlock also has this issue.

comment:4 Changed 5 years ago by mapx

  • Priority changed from Unknown to P2

comment:5 Changed 5 years ago by philll

  • Resolution set to duplicate
  • Status changed from new to closed

Probably a dublicate of #264

comment:6 Changed 5 years ago by mapx

I don't think is something like #264

There was a bug in the ABP for chrome apparently fixed. See:
https://adblockplus.org/forum/viewtopic.php?f=11&t=8720

#369 is reported for safari, #264 is for IE (don't share such much code)

Last edited 5 years ago by mapx (previous) (diff)

comment:7 Changed 5 years ago by mapx

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:8 Changed 5 years ago by sebastian

  • Owner set to sebastian
  • Status changed from reopened to assigned

comment:9 Changed 5 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce. We use .sheet.addRule() that the CSS we inject, don't show up in cases like that.

Are you sure that you are using Adblock Plus and that it is your only adblocking extension?

Last edited 5 years ago by sebastian (previous) (diff)

comment:10 Changed 5 years ago by mapx

  • Cc mapx added; smultron45@… removed
  • Component changed from Core to Platform
  • Platform set to Chrome
  • Resolution worksforme deleted
  • Status changed from closed to reopened

another user report the same behaviour but only in OSX ! in windows 7 it's all ok for him

see
https://adblockplus.org/forum/viewtopic.php?f=10&t=24401

comment:11 Changed 5 years ago by mapx

  • Cc greiner added

comment:12 Changed 5 years ago by sebastian

  • Cc fhd philll added

Back then I could sign up for a trial account without even providing payment information. However, now you need to pay at least 9.99 USD per month for Office 365.

But given how we inject our CSS, how few users have reported that issue, and that I couldn't reproduce it back then, I think it is rather unlikely that Adblock Plus is causing that behavior.

@fhd, philll: However I wouldn't mind looking in that issue again, if you can get us an Office 365 account for testing. If you think this isn't worth the hassle feel free to close the issue again.

Version 0, edited 5 years ago by sebastian (next)

comment:13 Changed 5 years ago by fhd

You've got a subscription now Sebastian - this does look like something we want to fix if we can.

Last edited 5 years ago by fhd (previous) (diff)

comment:14 Changed 5 years ago by Bezoar

I've been seeing this in Chrome for at least the last two days; a customer blocked my email address because of a spam link (sfippa.com) in the enclosed CSS at the pastebin link above. I unblocked Office365 to work around this for the time being, but since I can't (yet) get my employer to move off of Office365, I'll gladly try out any fix that may be forthcoming.

Chrome 37.0.2062.94
OS X 10.9.4
MacBook Pro 2011

Last edited 5 years ago by Bezoar (previous) (diff)

comment:15 Changed 5 years ago by sebastian

  • Ready set

I finally can reproduce the issue. As workaround until it is fixed, you can just whitelist outlook.office365.com (click ABP icon, toggle "Enabled on this site", reload page).

Last edited 5 years ago by sebastian (previous) (diff)

comment:16 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from reopened to closed

Apparently the stylesheet is injected into the light DOM again on Chrome, exposing it to the website's JavaScript. However, #1290 will fix this issue for recent versions of Chrome.

We are still using .sheet.insertRule() to avoid mess like that, regardless of Shadow DOM. But for some reason Outlook 365 serializes our style element, which is pretty silly on their end.

However, there is nothing we can do here to fix this issue for browsers that don't support Shadow DOM. So I close this issue as invalid. However, you can still whitelist Outlook 365, if necessary.

Last edited 5 years ago by sebastian (previous) (diff)
Note: See TracTickets for help on using tickets.