Opened 5 years ago

Closed 5 years ago

Last modified 12 months ago

#3706 closed change (fixed)

Upgrade Puppet patch version

Reported by: matze Assignee: matze
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fred, fhd Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):


Puppet issues 21409 (fixed in 3.3.0) and 13567 (fixed in 2.7.14) affect a lot of our code since we're using more and more separation between data (from Hiera/ENC/YAML) and logic (in Puppet/Ruby). In particular they prohibit us from using Puppet namevars in any parameter set that is not hard-wired. While in some cases we are lucky not triggering the issues just yet, other cases need to get tackled with pretty dirty workarounds.


The patch-set for Puppet issue 13567 is actually a partial fix for the namevar problematic (21409 fixes custom namevars other than $name). Upgrade to Puppet 2.7.14+ in order to include that fix and to allow for continuing the Hiera/ENC integration (which is considered a prerequisite for a Puppet major version update).

Change History (7)

comment:1 Changed 5 years ago by matze

  • Cc fhd added
  • Owner set to matze

comment:2 Changed 5 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Note that in development environment we're using an Ubuntu image with Puppet pre-installed, thus the setup script now produces a bunch of unfortunate warnings about over-written files during first provision.

comment:3 Changed 5 years ago by matze

Existing hosts need to be migrated manually though (we do not manage Puppet in Puppet), which we will do in the next days.

comment:4 Changed 5 years ago by matze

While the first patch-set works perfectly well with development images, the production one results in the following error:

The following packages have unmet dependencies:
 puppet-common : Depends: facter (< 2.0) but 2.4.6-1puppetlabs1 is to be installed
                 Recommends: debconf-utils but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Pinning facter seems to solve the issue:

Package: facter
Pin: version 1.*
Pin-Priority: 501

Another patch-set will follow soon.

comment:5 Changed 5 years ago by abpbot

A commit referencing this issue has landed:

comment:6 Changed 5 years ago by matze

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed

comment:7 Changed 16 months ago by AdamEvans


Last edited 12 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.