Opened 3 years ago

Closed 3 years ago

#3715 closed defect (worksforme)

Subscription still disabled after removing it and adding it again

Reported by: mapx Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian, greiner, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

windows 7
ABP 1.10.2.1557

How to reproduce

  1. add easylist germany (or any other new list)
  2. go to ABP options
  3. disable easylist germany
  4. delete (remove) the entry
  5. add again (from https://adblockplus.org/en/subscriptions ) easylist germany

Observed behaviour

  • the list will be added but just disabled

Expected behaviour

  • the list should be added already enabled

Change History (6)

comment:1 Changed 3 years ago by mapx

  • Description modified (diff)

comment:2 Changed 3 years ago by greiner

Sounds quite similar to #3451. Generally, #3468 might be useful to avoid further issues with caches not being emptied.

comment:3 follow-up: Changed 3 years ago by sebastian

  • Platform changed from Chrome to Unknown / Cross platform
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from ABP 1.10.2.1557 options, adding subscription already disabled to Subscription still disabled after removing it and adding it again

I actually though that this is by design. I discussed a similar issue with palant in the past, where disabled filters (on Firefox) are still disabled after re-adding the subscription, and he objected fixing it. However, the case here seems to be slightly different and given that we fixed it in Adblock Plus for Firefox (#3451), we should behave consistently here.

comment:4 in reply to: ↑ 3 Changed 3 years ago by greiner

Replying to sebastian:

given that we fixed it in Adblock Plus for Firefox (#3451), we should behave consistently here

I'd just like to point out that #3451 was about disabled filters, not disabled subscriptions.

comment:5 Changed 3 years ago by sebastian

You are right. In fact, that's actually the issue I found a while ago, and palant didn't want to have fixed. I guess he changed his mind. Even more, we should fix the related issue here as well.

comment:6 Changed 3 years ago by wspee

  • Resolution set to worksforme
  • Status changed from new to closed

Tested on Win7 Chrome 54.0.2480.50 ABP 1.12.4, Linux Chrome 55.0.2883.87 ABP 1.12.4 and Opera 42.0.2393.94 ABP 1.12.4.

Note: See TracTickets for help on using tickets.