Opened 4 years ago

Closed 4 years ago

#3720 closed defect (invalid)

Installing ABP to Chrome on OS X kicks user back to OS X login screen

Reported by: Ross Assignee:
Priority: P1 Milestone:
Module: Unknown Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description (last modified by Ross)

Environment

ABP 1.10.2.1557
Reproduced with:

  • Chrome 48 / 47 / 46 / OS X 10.11
  • Chrome 48 / OS X 10.10

Could not reproduce with:

  • Chrome 44 / OS X 10.8
  • Chrome 45 / OS X 10.11

How to reproduce

  1. Open Chrome 48/47/46 on OS X 10.11
  2. Attempt to install the latest ABP development build (link)
  3. Observe the OS X user get kicked back out to the login screen.

Observed behaviour

As Chrome attempts to install the extension the user is kicked back out to the OS X login screen.

Expected behaviour

Extension to install successfully / not crash user session.

Attachments (1)

InstallABP.crash (39.5 KB) - added by Ross 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by Ross

  • Description modified (diff)

comment:2 Changed 4 years ago by Ross

I thought this was caused by something about my local 10.11 OS X VM but I can reproduce it on the testing machines we have as well. Every build back to 1534 (so far) seems to cause it. Jumping back to 1504 installs okay/as expected. After a couple of reproductions Chrome starts to complain about not being able to read/write it's profile folder.

Doesn't occur on Mario's real OS X machine though...

Last edited 4 years ago by Ross (previous) (diff)

Changed 4 years ago by Ross

comment:3 Changed 4 years ago by Ross

  • Milestone Adblock-Plus-1.11-for-Chrome-Opera-Safari deleted

This actually occurs with any extension (should have tried that first...) and seems to be a Chrome bug. From the log, it looks like Chrome attempts to perform a hardware accelerated animation/transition on install, which fails as the VM does not have hardware acceleration enabled.

comment:4 Changed 4 years ago by sebastian

  • Cc sebastian added
  • Resolution set to invalid
  • Status changed from new to closed

Feel free to that Chrome bug to upstream.

Note: See TracTickets for help on using tickets.