Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3729 closed defect (fixed)

Default size of Add filter popup window hides buttons / requires scrollbars

Reported by: Ross Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.11-for-Chrome-Opera-Safari
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29337873

Description

Environment

ABP 1.10.2.1558
Reproduced in:

  • Chrome 30 / 48 / Windows 7 x86
  • Opera 23 / Windows 7 x86
  • Opera 35 / Ubuntu 14.04 x64
  • Opera 19 / OS X 10.11

Looks fine / Not reproduced in:

  • Chrome 30 / 48 / Ubuntu 14.04 x64

How to reproduce

  1. Navigate to BBC News (or other site).
  2. Select the [ABP Icon] > [Block element].
  3. Select an element on the page or the BBC logo.
  4. Observe popup window for adding filters is too small / displays scrollbars.

Observed behaviour

In Chrome: The default size of the popup seems too small on Windows (but not Ubuntu) and displays scrollbars.
In Opera: The default size of the popup is too small *and* the Opera address bar / ABP is included at the top.

See attached images.

Expected behaviour

Popup to be sized correctly / not include browser address bar (as attached Chrome-Ubuntu.png image)

Attachments (5)

Chrome-Ubuntu.png (450.2 KB) - added by Ross 4 years ago.
Chrome-Windows.png (458.3 KB) - added by Ross 4 years ago.
Opera-Ubuntu.png (192.2 KB) - added by Ross 4 years ago.
Opera-Windows.png (592.2 KB) - added by Ross 4 years ago.
Opera-OSX.png (599.8 KB) - added by Ross 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by Ross

Changed 4 years ago by Ross

Changed 4 years ago by Ross

Changed 4 years ago by Ross

Changed 4 years ago by Ross

comment:1 Changed 4 years ago by sebastian

  • Owner set to sebastian
  • Ready set

It seems that problem is that the size given to chrome.windows.create() specifies the size of the whole window, including decoration and address bar if any. And since the size of the window decoration varies across different environments, the content might or might not fit. BTW, Opera showing an address bar in the first place seems to be a bug on their end. Anyway, We can simply make the size of the text field variable, automatically consuming as much space as there is left. So that we will never get scrollbars, and even have a decent user experience when the the window is resized by the user.

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/937dc9577ad9

comment:4 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 4 years ago by Ross

  • Verified working set

Fixed. Seems to works well across browser platforms/versions.

ABP 1.10.2.1559
Chrome 30 / Windows 7 x86
Chrome 47 / Windows 7 x86
Chrome 38 / OS X 10.11 x64
Chrome 48 / Ubuntu 14.04 x64
Opera 19 / Windows 7 x86
Opera 35 / Windows 7 x86
Opera 25 / OS X 10.11 x64
Opera 35 / Ubuntu 14.04 x64
Safari 6 (OS X 10.8) / Safari 8 (OS X 10.10) / Safari 9 (OS X 10.11)

Last edited 4 years ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.