Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3734 closed defect (fixed)

History page rendering failing

Reported by: michal.kuric Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description

Environment

iOS 8.4.1
iPhone 5c
v1.3.0-qa (core 1.3.6-qa)

How to reproduce

  1. Open enough web pages to fill the history page (e.g. 8 pages)
  2. Open html5demos.com/history
  3. Tap to address bar
  4. Swipe to history

Observed behaviour

Pages from history are rendered in a way that everything which is out of view port isl not rendered at all and there is a blank space instead of items. User has to close the web page and restart app (kill/start) to see the history again

EDIT: there doesn't have to be

Expected behaviour

Full history should be rendered and displayed.

Change History (3)

comment:1 Changed 4 years ago by michal.kuric

Can't reproduce on the latest builds (QA 851).

comment:2 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.3.0
  • Priority changed from Unknown to P3
  • Ready set
  • Resolution set to fixed
  • Status changed from new to closed

After further investigation we found out that the cause to this issue was fixed by internal refactoring for build 850.

Last edited 4 years ago by mario (previous) (diff)

comment:3 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • Full history is rendered and displayed correctly.

ABB 1.3.0-qa (852)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.