Opened 4 years ago

Closed 4 years ago

#3736 closed defect (fixed)

Regression: Check for blocked social resources fails

Reported by: greiner Assignee: greiner
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: saroyanm Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29337878/

Description (last modified by greiner)

Environment

Chrome 49.0.2623.75 (64-bit)
Adblock Plus 1.10.2

How to reproduce

  1. Open first-run page
  2. Enable "Remove social media buttons" feature
  3. Click on Twitter button in share section

Observed behaviour

Overlay is loaded and content fails to load.

Expected behaviour

https://twitter.com/adblockplus opens in a new tab.

Background

This is caused by a change in the function signature of Matcher.matchesAny() (see #2738). Previously, it accepted the request type to be specified as a string (e.g. "SCRIPT") but now it only accepts a number (e.g. RegExpFilter.typeMap["SCRIPT"]).

What to change

Change
defaultMatcher.matchesAny(..., message.requestType, ...)
to
defaultMatcher.matchesAny(..., RegExpFilter.typeMap[message.requestType], ...)
in messageResponder.js

Change History (6)

comment:1 Changed 4 years ago by greiner

  • Owner set to greiner

comment:2 Changed 4 years ago by greiner

  • Description modified (diff)

comment:3 Changed 4 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 4 years ago by greiner

  • Ready set

comment:5 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/da160389eb39

comment:6 Changed 4 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.