Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3761 closed change (fixed)

Don't clear user input when filter validation failed on the new options page

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: #3763 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29338005
https://codereview.adblockplus.org/29338939

Description

Background

While the old options page and the "Block element" dialog preserves user input when filter validation failed, the new options page currently clears the user input regardless of errors.

This is a user experience regression. When you typed some filter(s) which couldn't be saved due to a typo, you want to simply fix that issue, and not enter everything over again.

What to change

Instead emitting app.error when filter validation failed, always respond to the original message indicating errors if any. The UI code should then handle the response and only clear input or leave editing mode if the filters were added successfully.

Change History (7)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

  • Blocking 3763 added

comment:3 Changed 4 years ago by greiner

  • Ready set

comment:4 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/e23fe878fabb

comment:5 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)

comment:7 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/e6bca33c2837

Note: See TracTickets for help on using tickets.