Opened 4 years ago

Closed 11 months ago

#3762 closed defect (rejected)

Old filter list is not replaced with the new one when updating ABB/Sbrowser.

Reported by: scheer Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: Blocked By:
Blocking: Platform: Samsung Browser
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

We currently have the issue that, if the user selects to only ever update Easylist via Wifi, that they will never receive an updated version of Easylist.

To bypass this, when a new version of the app is available, the user should be able to receive the most up to date easylist version from it, so that they can stay partially up-to-date and have larger Easylist issues fixed.

Currently the issue is, that the old filter list is not replaced with the new list when the app is updated.

Environment

Samsung Galaxy S6
Android Version 5.1.1
ABP for SBrowser 1.0.1-20160304092800

How to reproduce

  1. Download and install the app
  2. Ensure that you have a sim card installed
  3. Select 'Configure automatic updates'
  4. Select 'On Wifi only'
  5. Disconnect the Wifi on the device and ensure that Cellular data is on
  6. Update the app to the version with the fixed filter list

Observed behaviour

Updating ABP does not replace the filter list when updating to the latest ABP version.

Expected behaviour

Updating the version via cellular data should also replace the old filter list.

Change History (2)

comment:1 Changed 2 years ago by jwangenheim

The current technical status is as follows: When the user installs the app and starts it for the first time, the list that best suits him or her is automatically selected and downloaded in the latest version - regardless of his or her update settings.

We can use the migrateFromPreviousVersion() method to check if a new version was installed. If true we could add the filters from the bundles lists wich are new.

comment:2 Changed 11 months ago by jchee

  • Resolution set to rejected
  • Status changed from new to closed

Closing ticket as it has been moved to Gitlab:
https://gitlab.com/eyeo/adblockplus/adblockplussbrowser/issues/14

Note: See TracTickets for help on using tickets.