Opened 21 months ago

Closed 5 months ago

#3769 closed defect (fixed)

UI colours gone bad

Reported by: rjeschke Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29348083/

Description (last modified by diegocarloslima)

We need to exhaustively test the changes Mozilla did to the UI and its colours.

First issue is already the new search screen (see attached image).

The style guide of ABB can be found here: https://drive.google.com/drive/u/0/folders/0BwuqgB4SCPsPfjdFV19NU1pTRE5ZaFpjd3AzZlo4c2RtV0U0dHYzVTlIUDZGcEpUTHhhWUU

Attachments (10)

grey-on-grey.png (109.4 KB) - added by rjeschke 21 months ago.
The new search screen
colors 4.psd (2.4 MB) - added by diegocarloslima 12 months ago.
default screen style guide 4.png (137.2 KB) - added by diegocarloslima 12 months ago.
incognito screen style guide 4.png (130.7 KB) - added by diegocarloslima 12 months ago.
mark screen style guide 4.png (284.8 KB) - added by diegocarloslima 12 months ago.
tab screen style guide 4.png (116.4 KB) - added by diegocarloslima 12 months ago.
active_tab_text_color.png (58.0 KB) - added by diegocarloslima 5 months ago.
history_hint_color.png (84.7 KB) - added by diegocarloslima 5 months ago.
tools_downloads_color.png (38.5 KB) - added by diegocarloslima 5 months ago.
settings_display_colors.png (115.4 KB) - added by diegocarloslima 5 months ago.

Download all attachments as: .zip

Change History (19)

Changed 21 months ago by rjeschke

The new search screen

comment:1 Changed 17 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:2 Changed 15 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 13 months ago by diegocarloslima

  • Description modified (diff)

comment:4 Changed 12 months ago by fhd

Can you please attach the style guide to the issue?

Changed 12 months ago by diegocarloslima

Changed 12 months ago by diegocarloslima

Changed 12 months ago by diegocarloslima

Changed 12 months ago by diegocarloslima

Changed 12 months ago by diegocarloslima

comment:5 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 3769 - UI colours gone bad

comment:6 Changed 11 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 months ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer

In colours 4.png the mask for private mode is purple, but in the latest build it is grey with a whiled next to it. It would be quite hard to confirm these changes are correct without an up-to-date style guide to reflect the correct intended changes here. As for the main issue shown in the first screenshot (grey-on-grey.png) this no longer occurs, but as there was no device specified, I can only confirm that particular fix on a Galaxy S7, Android 7.0. Could we update this ticket with an explanation or new style guides so I can confirm that the correct UI colours are shown across the areas of concern, or maybe just a screenshot of the currently known areas that *were* broken?

comment:8 Changed 5 months ago by diegocarloslima

Our style guide was made based on Firefox 40.0, so some icons have changed in Firefox 44.0.2. The private mask icon is one of them, Mozilla changed it from a purple icon to a grey one. Since we don't have a detailed style guide that is based on Firefox 44.0.2 and many stuff changed, I had to do my best interpretation of the old guide and only changed what I considered that was relevant (mostly removing orange stuff, that doesn't belongs to our color palette). I'll attach some screenshots of mostly what was 'wrong' and how it was changed. My opinion is that once we have a more detailed style guide, we might revisit the icons/colors again and make the appropriate changes.

Changed 5 months ago by diegocarloslima

Changed 5 months ago by diegocarloslima

Changed 5 months ago by diegocarloslima

Changed 5 months ago by diegocarloslima

comment:9 Changed 5 months ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set
  • As mentioned, all colours are now displayed correctly.

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.