Opened 4 years ago

Closed 4 years ago

#3775 closed defect (fixed)

abpcrawler does not log requests anymore

Reported by: sergz Assignee: sergz
Priority: P2 Milestone:
Module: Extensions-for-Adblock-Plus Keywords: abpcrawler
Cc: trev Blocked By:
Blocking: #3780 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29338121/

Description (last modified by sergz)

Environment

ABP 2.7.2
Firefox 44.0.2
abpcrawler https://hg.adblockplus.org/abpcrawler/rev/97d6d474f958

How to reproduce

  • run it

Observed behaviour

In a json file in the output directory there is no property requests.

Expected behaviour

In in json file corresponding to each URL there should be an array property request where each entry contains location, request type and filters applied for the request.

Additional note

It seems filters are broken already quite a long and since https://github.com/adblockplus/adblockplus/commit/be90043a03f70b68be0571a118862a298c2b7a77 abpcrawler has stopped to save even request locations because abpcrawler used Policy.processNode from lib/contentPolicy.js.

To get similar behavior we can use RequestNotifier in the chrome (parent process) script.

Change History (7)

comment:1 Changed 4 years ago by sergz

  • Description modified (diff)

comment:2 Changed 4 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by sergz

  • Blocking 3780 added

comment:4 Changed 4 years ago by trev

  • Component changed from Unknown to Extensions-for-Adblock-Plus
  • Priority changed from Unknown to P2
  • Ready set

comment:5 Changed 4 years ago by trev

  • Cc trev added

comment:6 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/abpcrawler/rev/dc06ad9017b8

comment:7 Changed 4 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.