Opened 4 years ago

Closed 4 years ago

#3780 closed defect (fixed)

abpcrawler should wait for the loading of filters and only afterwards start to fetch pages

Reported by: sergz Assignee: sergz
Priority: P2 Milestone:
Module: Extensions-for-Adblock-Plus Keywords: abpcrawler
Cc: trev Blocked By: #3775
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29338153/

Description

Environment

ABP 2.7.2
Firefox 44.0.2
abpcrawler ​https://hg.adblockplus.org/abpcrawler/rev/97d6d474f958

How to reproduce

Since there is a race condition, sometimes it's quite difficult to reproduce it.

  • host a simple page with some blocked resource (e.g. <img src=".../adriver/blockme"/> for current easylist because it contains /adriver/* fitler, or use your own filter list)
  • run crawler with a single URL to the page above

Observed behaviour

There are no matching filters.

Expected behaviour

There should be matching filter.

Additional note =

It seems we should use FilterNotifier to firstly wait for load event and then start to open pages. Alternative way is to use extensions.adblockplus.please_kill_startup_performance though it does not look like a good long term solution.

Change History (5)

comment:1 Changed 4 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by trev

  • Component changed from Unknown to Extensions-for-Adblock-Plus
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 4 years ago by trev

  • Cc trev added
  • Owner set to sergz

comment:4 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/abpcrawler/rev/b8d3bb27775f

comment:5 Changed 4 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.