Opened 4 years ago

Closed 4 years ago

#3784 closed defect (fixed)

[hgreview] Review title is too long, description is cut off

Reported by: fhd Assignee: trev
Priority: P3 Milestone:
Module: Unknown Keywords: hgreview
Cc: trev Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29338144/

Description

Environment

hgreview extension revision 2e155c15c704

How to reproduce

  1. Commit something with a commit message in the canonical format:

Noissue - This is the short title

This is the body of the commit message with more information.

  1. Upload a review for this change with hg review -c ...

Observed behaviour

  1. The title of the uploaded review contains not only the first line of the commit message, but the entire message. It gets truncated after 100 characters.
  2. The description of the uploaded review contains the entire commit, but truncated after (presumably) 100 characters.

Expected behaviour

  1. The title of the review should just be the first line of the commit message.
  2. The description of the review should be the entire commit message (including the first line), untruncated.

Change History (8)

comment:1 Changed 4 years ago by trev

That's an upload.py or Rietveld bug actually. We should be able to work around it by always setting -m parameter if it isn't given.

comment:2 Changed 4 years ago by fhd

Don't think it's a bug. Seems like upload.py has logic for using the title for both title and description if only --title is specified. And since the title has to be truncated to fit...

IIRC, upload.py automatically sets the title to the first line of the message if only --message is specified, so that should do.

Last edited 4 years ago by fhd (previous) (diff)

comment:3 Changed 4 years ago by trev

We'll have to use both anyway, see #3779. And - no, I don't like relying on implicit behavior.

comment:4 Changed 4 years ago by trev

  • Owner set to trev

comment:5 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 4 years ago by trev

  • Keywords hgreview added

comment:7 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/codingtools/rev/44c64a377f3c

comment:8 Changed 4 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.