Opened 4 years ago

Closed 21 months ago

Last modified 7 months ago

#3791 closed defect (rejected)

AdBlock Plus fails to block pop-up/banner ads (2 sites as examples)

Reported by: anon12345 Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 7 64-bit w/ SP1 up to date, Firefox 45, Google Chrome Version 49.0.2623.87 m, Firefox (2.7.2), Chrome (Adblock Plus 1.11) both use identical Filter lists: Malware Domains, Easy List and Easy Privacy.

How to reproduce

  1. Go to http://kevinmd.com/ (The annoying Pop up asking to sign up for newsletter. You may have to scroll down to bottom of the page and view a few articles, or view 2-3 articles. and http://www.windowsdeal.com (Persistent, annoying).

Browse to www.MSN.com and you will get the same type AD, trying to convince you to upgrade to Windows 10 (In my case when logging out from www.outlook.com.

  1. Step two of your reproduction process (e.g: Click the big red button labelled "click me" at the left)
  2. Try to add to filter lists as an exception (you cannot add all parts on either browser - at minimum part of it still shows up and blocks the view. Pop-up blocker is enabled in all browsers).I am about to install AdBlockPlus for IE 11. If it does not appear, leave the page unattended for 30-60 seconds after fully loaded, it will.
  3. This has ben happening for at minimum 1 year, I just never took the time to report it.

... (note names obscured from ads to avoid any copyright or complaint issues).

Observed behaviour

Despite using all available settings, making sure filters are updated and making sure "Allow some non-intrusive advertising is disabled in all browsers).

Expected behaviour

I am not sure what type of ad you would technically classify this ad, but please block these type of obtrusive ads!

Attachments (2)

Ad1.jpg (53.4 KB) - added by anon12345 4 years ago.
Screenshots of Ads (excluding msn.com one)
Newsletter ad.jpg (40.8 KB) - added by anon12345 4 years ago.
Newsletter pop-up ad

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by anon12345

Screenshots of Ads (excluding msn.com one)

Changed 4 years ago by anon12345

Newsletter pop-up ad

comment:1 Changed 4 years ago by greiner

  • Cc greiner added

Thank you for taking the time to report it to us.

I tried to follow your steps but I'm not sure whether I understand what exactly the issue is.

  1. Self promotions such as that "newsletter ad" are not paid and therefore not blocked by EasyList. You'd have to add another filter list to get rid of such annoying messages (see adblockplus.org/subscriptions).
  1. I couldn't reproduce the windowsdeal.com ad but it looks very much like a scam site. Therefore this ad may have been injected by adware which you could check for using Malwarebytes.

Note that you can also report issues directly from within the extension. Just click on the Adblock Plus icon and select "Report issue on this page..." and it will gather all sorts of useful data that might be helpful to resolve such an issue.

comment:2 Changed 21 months ago by kzar

  • Cc kzar added
  • Resolution set to rejected
  • Status changed from new to closed

comment:3 Changed 7 months ago by max456

Last edited 7 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.