Opened 18 months ago

Closed 11 months ago

Last modified 3 months ago

#3820 closed defect (fixed)

Selecting Settings within ABB for Android causes the app to crash.

Reported by: scheer Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: #2512, #4237 Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29341235/

Description

If the user attempts to open Settings whilst on a website or in the dashboard, the app crashes.

Environment

adblockbrowser-1.1.1-42.0.2-20160317113800-testing
Samsung Galaxy S6 - Android 6.0

How to reproduce

  1. Open the app and select Options from the top right
  2. Select Settings

Observed behaviour

The app crashes with the error message 'Unfortunately, Adblock Browser has stopped'.

Expected behaviour

The user is taken to the settings page.

Attachments (1)

settings_crash.log.txt (17.5 KB) - added by rjeschke 18 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 18 months ago by mapx

  • Component changed from Adblock-Plus-for-Android to Adblock-Browser-for-Android

comment:2 Changed 18 months ago by rjeschke

  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 18 months ago by rjeschke

So far no luck reproducing this on my Android 4.4.4 device, currently upgrading my S6 to Android 6.

Will try with my Nexus5/Android 6 in the meantime.

Changed 18 months ago by rjeschke

comment:4 Changed 18 months ago by rjeschke

Okay, could reproduce this with the Nexus5/Android6, attached crash log just for reference.

comment:5 Changed 17 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:6 Changed 17 months ago by diegocarloslima

This crash happens because when PreferenceActivity gets inflated, it tries to read the colorPrimary styling attribute (not the android:colorPrimary one), and since it could find it in the current theme, it throws an exception

comment:7 Changed 17 months ago by diegocarloslima

  • Status changed from new to reviewing

comment:8 Changed 17 months ago by diegocarloslima

  • Review URL(s) modified (diff)

comment:9 Changed 15 months ago by rjeschke

  • Blocking 4237 added

comment:11 Changed 11 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:12 Changed 11 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next

comment:13 Changed 11 months ago by diegocarloslima

  • Blocking 2512 added

comment:14 Changed 3 months ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • The app no longer crashes when entering the settings menu.

ABB adblockbrowser-1.1.1.20170612182010-arm
Nexus 5
Android 6.0.1

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.