Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3824 closed defect (fixed)

Move "use strict" into IIFE for compatibility with Kitt

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29338529

Description

Kitt, the platform of Adblock Browser for iOS, concatenates all background scripts, rather than executing them as separate scripts. Therefore the top-level "use strict" in the polyfills add with #3515 don't have any effect, except for the very first one which turns on strict-mode for all background code, essentially breaking the extension. If that is because of strict mode is enabled for everything, or because another Kitt-specific issue with strict-mode isn't clear yet. But either way, moving "use script" in the IIFE fixes it.

Change History (4)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/85eb7ccf3634

comment:3 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Change doesn't look to have caused any obvious regressions.

ABP 1.11.0.1606
Chrome 31, 45, 50 / Windows 7
Chrome 32, 49 / OS X 10.11
Chrome 49 / Ubuntu 14.04

Note: See TracTickets for help on using tickets.