Opened 5 years ago

Closed 5 years ago

#383 closed defect (rejected)

uninstalling ABP from a rooted Android device blocks non-https browsing

Reported by: philll Assignee:
Priority: P1 Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Reported user case: Galaxy S GT-I9000 rooted with SlimKat v4.4.2
Affirmed case: Nexus 7 rooted with Android 4.4.2
ABP from dev builds with filtering switched on

How to reproduce

  1. Uninstall ABP from the phone
  2. With any given browser, try to open a non-https page
  3. Open an https page

Observed behaviour

The non-https page cannot be loaded, the https-page loads fine. In a first test with switched off ABP filtering, browsing worked well after uninstalling. Apparently, after having ABP uninstalled in a second test with switched on filtering, a third trial with switched off filtering again does not fix the browsing behaviour again.

Taken from https://adblockplus.org/forum/viewtopic.php?f=11&t=22742&sid=c7f95328ef63b7a3731b4990a8538f4c

Expected behaviour

Both pages should load.

Change History (3)

comment:1 Changed 5 years ago by CalebFnord

OP here.

Not sure what I did, but it involved several installs, disabling filtering and uninstalls, which didn't seem to work, and finally a hard reset (press and hold Galaxy S power button) is what did it - browsing is restored to normal. Sorry I can't be more helpful, I didn't methodically debug this.

comment:2 Changed 5 years ago by rjeschke

This is currently not fixable because we don't have a reliable way to get notified on force-close and uninstall.

Workaround:

  • tell users to disable ABP before uninstalling
  • if they forget to disable the proxy, restarting the phone fixes the issue

comment:3 Changed 5 years ago by rjeschke

  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.