Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3830 closed defect (fixed)

Filters saved through "Block element" override existing filters

Reported by: mapx Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: User-Interface Keywords:
Cc: sebastian, kzar, greiner Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29338614

Description (last modified by mapx)

Environment

windows 10
chrome 50
ABP 1.11.0.1572

How to reproduce

  • add a custom filter (manually or using "block element")
  • go to whatever page, click ABP icon, use "block element" ==> create a new filter.
  • see the custom filters ==> the first filter(s) was removed

the stable 1.11 is working fine.

Change History (12)

comment:1 Changed 4 years ago by mapx

  • Description modified (diff)

comment:2 Changed 4 years ago by mapx

  • Cc greiner added

comment:3 Changed 4 years ago by greiner

I assume this is a regression from #3761 because it turns out that the filters.importRaw message not only adds new filters but also removes other filters because it was initially only meant for being used for the custom filters textbox in the options page.

Therefore we could either extend the filters.importRaw message or even merge it with filters.add to achieve the expected behavior.

comment:4 Changed 4 years ago by sebastian

  • Component changed from Platform to User-Interface

I confirm, greiner's conclusion. To fix that, I suggest to add an option to filter.importRaw indicating whether to remove existing filters. I'm not sure about merging filters.importRaw and filters.add though since the code diverge seems to be quite large.

comment:5 Changed 4 years ago by sebastian

  • Owner set to sebastian

comment:6 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from dev build 1.11.0.1572 breaks the custom filters feature to Filters saved through "Block element" override existing filters

comment:7 Changed 4 years ago by greiner

  • Ready set

comment:8 Changed 4 years ago by greiner

  • Priority changed from Unknown to P1

comment:9 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/7379383afc15

comment:10 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/db3cf8c1ec2c

comment:11 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:12 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

ABP 1.11.0.1597
Chrome 32 / 50 / Windows 10
Opera 23 / 36 / Windows 10
Chrome 32 / 50 / OS X 10.11
Opera 23 / 36 / OS X 10.11
Safari 6 / 7 / 9.1 / OS X 10.8/10.9/10.11
Chrome 50 / Ubuntu 14.04

Last edited 4 years ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.