Opened 20 months ago

Closed 3 months ago

#3832 closed defect (worksforme)

Ad blocking does not function at all

Reported by: scheer Assignee:
Priority: P2 Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

With the current build, ad blocking does not functional at all, with the ad box checked or unchecked, all ads get through.

Environment

adblockbrowser-1.1.1-42.0.2-20160317113800-testing
Samsung Galaxy S6
Android 6.0

How to reproduce

  1. Tap on the More Options icon from the top right in ABB
  2. De-select the checkbox on the 'Block ads on this site' option
  3. Open msn.com
  4. Tap on the More Options icon from the top right in ABB
  5. Select the checkbox on the 'block ads on this site' option
  6. Reload msn.com

Observed behaviour

No ads are blocked.

Expected behaviour

When 'Block ads on this page' is checked, ads should be blocked.
When 'Block ads on this page' is un-checked, ads should be allowed to be displayed.

Change History (6)

comment:1 Changed 20 months ago by scheer

  • Description modified (diff)
  • Summary changed from Ad Blocking does not functional at all to Ad blocking does not function at all

comment:2 Changed 20 months ago by rjeschke

  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 20 months ago by rjeschke

Could you please check if any filter list is selected in the settings?

I had this issue with my Android 4.4.4 device, i.e. no ads were blocked. Strangely there wasn't any filter list enabled.

Will need to investigate, however, why there's no filter list selected by default.

comment:4 Changed 20 months ago by scheer

Currently, I am unable to select settings because of #3820. Once that is fixed and if then the issue still occurs, I will re-check the issue then.

comment:5 Changed 3 months ago by diegocarloslima

This issue seems to be solved. I'm unable to reproduce it.

Environment

abb-merge-45-0-2-build-3-signed-zipaligned.apk
Samsung Galaxy S7 edge
Android 7.0

comment:6 Changed 3 months ago by diegocarloslima

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.