Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3838 closed defect (fixed)

[ABB for iOS] pt-BR not displayed on iOS 8.4

Reported by: Shikitita Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: pavelz, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Shikitita Verified working: yes
Review URL(s):

Description (last modified by Shikitita)

Environment

Platform: iPhone 5s
Operating system: iOS 8.4
Browser: Adblock Browser v1.3.0-qa (core 1.3.6-qa)

How to reproduce

  1. Install Adblock Browser for iOS for the first time
  2. Change the iPhone's language into Portuguese (Brazilian)
  3. Access Adblock Browser for iOS by tapping on its icon in the Home screen
  4. Tap on the + icon on the Dashboard, next to the "Adblock Plus" bookmark, in order to add a bookmark to the dashboard
  5. Observe the word "Feito" under "Dashboard"
  1. Change now the iPhone's language to "Portuguese (Brasileiro)" by tapping on Ajustes -> Geral -> Idioma e Região -> Outros Idiomas... -> Português (Brasileiro)
  2. Repeat steps 3 and 4


Observed behaviour

The translated word for "Done" displayed on the screen underneath "Dashboard" is the pt-PT translation "Feito".

However, after changing the language in step 6, the translation for "Done" displayed on the screen is the pt-BR translation "Pronto".

Expected behaviour

The pt-BR translations should be the ones always displayed on the screen when selecting "Portuguese (Brazilian)" on the iPhone.

Attachments (2)

IMG_0002.PNG (43.1 KB) - added by Shikitita 4 years ago.
pt-PT strings
IMG_0004.PNG (43.8 KB) - added by Shikitita 4 years ago.
pt-BR strings

Download all attachments as: .zip

Change History (15)

comment:1 Changed 4 years ago by mario

  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.3.0

comment:4 Changed 4 years ago by Shikitita

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 4 years ago by Shikitita

Strings have been copied now from Brazilian Portuguese to Portuguese (Brasileiro).

comment:6 follow-up: Changed 4 years ago by pavelz

@Shikitita i am confused by the references between reproduction steps and the fact that i don't understand portuguese so i don't know where the text "Relatórios de falhas" belongs and which one should be displayed when. Please confirm that you mean the "Adblock Unexpectedly Quit" popup which appears upon startup after "Crash Now". We don't control appearance and localization of that popup. We get whatever translations are provided by HockeyApp SDK. It happens to be pt and pt-PT, no pt-BR. To confirm/deny the synthetic pt-US translation, please provide another example from inside the app.

comment:7 Changed 4 years ago by Shikitita

  • Description modified (diff)

comment:8 in reply to: ↑ 6 Changed 4 years ago by Shikitita

Replying to pavelz:

@Shikitita i am confused by the references between reproduction steps and the fact that i don't understand portuguese so i don't know where the text "Relatórios de falhas" belongs and which one should be displayed when. Please confirm that you mean the "Adblock Unexpectedly Quit" popup which appears upon startup after "Crash Now". We don't control appearance and localization of that popup. We get whatever translations are provided by HockeyApp SDK. It happens to be pt and pt-PT, no pt-BR. To confirm/deny the synthetic pt-US translation, please provide another example from inside the app.

@Pavelz I actually meant the pop-up displayed when tapping on "Always" after a crash. This pop-up has information for the user of where they can always change that setting. However, I've modified the description for steps that should be shorter and easier to follow. Please let me know.

comment:9 Changed 4 years ago by Shikitita

  • Description modified (diff)

comment:10 Changed 4 years ago by Shikitita

  • Description modified (diff)

Changed 4 years ago by Shikitita

pt-PT strings

Changed 4 years ago by Shikitita

pt-BR strings

comment:11 Changed 4 years ago by pavelz

I have confirmed that both pt-BR and the copied synthetic pt-US have "Done" = "Pronto" in it. So the only left explanation is that the invalid iOS 8 locale "Portuguese (Brazilian)" is not represented as pt-US which the internets are suggesting, but something else. Needs to be checked. It is absolutely possible that we will have to live with "Portuguese (Brazilian)" fall to plain portuguese on iOS8 (which the internets are also suggesting)
http://stackoverflow.com/a/28611997

@Shikitita what would be a bigger disaster? Portugal displayed to brazilians, or brazilian displayed to portugal? HockeyApp seems to use brazilian for the default fallback, because their resources have just pt and pt-PT, no BR.

comment:12 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:13 Changed 4 years ago by Shikitita

  • Verified working set
Note: See TracTickets for help on using tickets.