Opened 5 years ago

Closed 3 years ago

#384 closed defect (worksforme)

Wrong image shows up briefly for Adblock Plus icon

Reported by: trev Assignee: trev
Priority: P4 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, arthur, trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5194794401792000/
http://codereview.adblockplus.org/6719238685327360/

Description

This isn't an issue I can reproduce but it is fairly obvious what is causing it. Here the original report from the blog:

The only problem I have is a “blinking” of the UI when Firefox starts : It seems like a line of icons appears and disappears at the top of the browser. Nothing really serious but it’s a bit annoying, and is clearly related to adblock+ as everything works fine when it’s disabled.

Background

Adblock Plus icon uses toolbar-1 class to ensure correct styling. Among the default styles for this class is the following:

list-style-image: url("chrome://browser/skin/Toolbar.png");

We override it in our own styles but it seems that under some conditions these style load after the button is inserted in the document - meaning that for a brief time chrome://browser/skin/Toolbar.png is displayed as the image here.

What to change

We can add style="list-style-image: none;" attribute to the icon, this will make sure that the default style cannot apply. Our styles can then override that attribute using !important flag.

Change History (14)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added

comment:2 Changed 5 years ago by arthur

  • Cc arthur added

I can reproduce this. Let me know if you need anything.

comment:3 Changed 5 years ago by trev

Only confirming once this is fixed - I'm fairly certain that the solution I outlined will do.

comment:4 Changed 5 years ago by trev

  • Owner set to trev

comment:5 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

Should be fixed: https://hg.adblockplus.org/adblockplus/rev/540b36aa0dc7

Arthur, there will be a new development build in five minutes, could you verify that this issue is really fixed?

comment:7 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next

comment:8 Changed 5 years ago by arthur

  • Resolution fixed deleted
  • Status changed from closed to reopened

It is still happening for me with 2.6.0.3812.

Apparently this bug doesn't seem to affect Firefox 29 with the new Australis design but the old one below 29.

comment:9 Changed 5 years ago by trev

  • Cc trev added
  • Owner trev deleted

Backed out the change: https://hg.adblockplus.org/adblockplus/rev/2aafe9a3a965

Unfortunately, I still cannot reproduce this, not even with Firefox 28.

comment:10 Changed 5 years ago by trev

  • Keywords goodfirstbug removed
  • Milestone Adblock-Plus-2.6.1-for-Firefox deleted

I was able to reproduce this on Windows with Firefox 28 by slowing down startup (added several filter subscriptions and made sure two fairly heavy tabs load on startup). The fix above indeed doesn't work for some reason, the style attribute is simply ignored. If I change attributes of the element then all the sudden the styles apply.

comment:11 Changed 5 years ago by trev

  • Owner set to trev

comment:12 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

In the end the only solution appears to be removing the toolbarbutton-1 class in Firefox. Not having it in Thunderbird apparently makes our icon look better as well. SeaMonkey is the only place where we actually need it, so I made sure it is added there (had to restore handling of defaultToolbarPosition.addClass which apparently got lost in the Australis update).

comment:13 Changed 5 years ago by philll

  • Platform set to Firefox

comment:14 Changed 3 years ago by trev

  • Resolution set to worksforme
  • Status changed from reviewing to closed
  • Tester set to Unknown

I'm closing these since we no longer support pre-Australis versions of Firefox.

Note: See TracTickets for help on using tickets.