Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3841 closed change (fixed)

Remove workaround stripping [style] selectors on certain websites

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29338761

Description (last modified by sebastian)

Background

In 2011, a bug in Chrome was found that broke some functionality in Google Mail (apparently Yahoo Mail was effected as well), when an extension injects any CSS rules using selectors that target the style attribute.

As a workaround Adblock Plus stripped all element hiding filters using such selectors on mail.google.com, www.google.com and mail.yahoo.com.

However, I cannot reproduce that issue anymore. And given that the bug is 5 years old chances that the same code in Chrome and/or Google Mail that caused the issue back then still exists is rather low anyway. If a similar bug still exists, it most likely effects a different set of websites.

What to change

Remove the workaround stripping selectors that target the style attribute on some websites.

Change History (7)

comment:1 Changed 4 years ago by sebastian

  • Summary changed from Remove workaround stripping [style] selectors on certain websites. to Remove workaround stripping [style] selectors on certain websites

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:4 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/15dabaeee975

comment:5 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 3 years ago by Ross

I'm unsure how I should test this? Check if advert filtering works in Google mail?

comment:7 Changed 3 years ago by sebastian

See the reproduction steps in the Chrome bug, but instead step 1. add the custom filter ##foobar > div[style] in Adblock Plus. Make sure that in particular on old Chrome versions Gmail doesn't break.

Note: See TracTickets for help on using tickets.