Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3844 closed defect (fixed)

Adblock Plus breaks CSSStyleSheet.deleteRule()

Reported by: jobp Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: arthur, sebastian, mapx Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29338800

Description

Environment

OS: Win10 Pro, Edition 1511, OS Build: 10586.122
Chrome: 49.0.2623.87
ABP: 1.11.0.1579
Filterlists: EasyList & Acceptable Ads

How to reproduce

  1. Select a video on the website dumpert.nl (example: http://www.dumpert.nl/mediabase/6738717/23fda8bd/niet_fucken_met_een_ninja.html)

Observed behaviour

The video and/or ad are not loading.

Expected behaviour

The video should play without any ads

Additional information

I checked together with Arthur that it is not a filterissue. Also, the problem cannot be reproduced in the 1.11 build of ABP, therefore, it seems to be a problem in the devbuild.

Change History (8)

comment:1 Changed 4 years ago by mapx

  • Cc sebastian mapx added

comment:2 Changed 4 years ago by mapx

error in console

VM71:12 Uncaught TypeError: CreateListFromArrayLike called on non-object
dumpert_v5.min.js?0.36:4 
Error handling "COMPLETE" event listener [0]: TypeError: f.html5.player is not a constructor 


error line:

      deleteRule.apply(this, index);

comment:3 Changed 4 years ago by sebastian

  • Owner set to sebastian

comment:4 Changed 4 years ago by sebastian

  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P1
  • Ready set
  • Summary changed from Videos on dumpert.nl not loading in the devbuild to Adblock Plus breaks CSSStyleSheet.deleteRule()

Yeah, it's supposed to be .call(this, index). For reference, this regression was introduced by #3699, and effects websites that use CSSStyleSheet.deleteRule() or CSSStyleSheet.removeRule().

comment:5 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/babb6eb342c7

comment:7 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed (and added this site to the list of site test cases).

ABP 1.11.0.1597
Chrome 32 / 50 / Windows 10
Opera 23 / 36 / Windows 10
Chrome 50 / Ubuntu 14.04

Note: See TracTickets for help on using tickets.