Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3852 closed defect (rejected)

Images take longer to load than other browsers

Reported by: scheer Assignee:
Priority: P2 Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario, pavelz Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by scheer)

In other browsers such as Safari, Chrome and Firefox on iOS, when visiting certain image heavy sites, the load time on the images is incredibly small, if not completely un-noticeable.

With ABB, compared to other browsers, the timing is very noticeable (4-5 seconds.

This also occurs on ABB 1.2.1

Environment

ABB 1.2.1 (740)
ABB 1.3.0-qa (859)
iPhone 6 Plus - iOS 9.2.1
Easylist English
AA Off
No other Blocking options enabled

How to reproduce

  1. Open msn.com in Chrome
  2. Open msn.com in Firefox
  3. Open msn.com in Safari
  4. Open msn.com in ABB iOS

Observed behaviour

In all browsers but ABB - the load time is almost instantaneous. In ABB, the load time of images can reach 5 seconds).

Expected behaviour

Image load times should match other browser speeds.

Change History (7)

comment:1 Changed 4 years ago by scheer

  • Description modified (diff)

comment:2 Changed 4 years ago by mario

  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 4 years ago by pavelz

I didn't have a serious look at it yet, but it would be insightful if you try to compare with the real technological contenders to ABB: Opera Mini, Dolphin, Mercury - these use the same "old" webview container, which ABB must continue using. All of Chrome, Firefox, Safari "cheat" by using the modernized iOS8+ webview container, which does not provide the needed control over loaded resources anymore. Chrome has switched to it just recently and actually lost a significant array of functions due to it. But the speed and improved stability was probably worth it.

Also please try comparing with Adblock extension switched off completely (not just AAs)

comment:4 Changed 4 years ago by pavelz

  • Cc pavelz added

comment:5 Changed 4 years ago by pavelz

  • Resolution set to rejected
  • Status changed from new to closed

Confirmed. Compare Opera Mini and Adblock Browser with Adblock Plus turned off. These are comparable contenders.

comment:6 Changed 4 years ago by pavelz

  • Milestone set to Adblock-Browser-for-iOS-next

comment:7 Changed 4 years ago by mario

  • Milestone Adblock-Browser-for-iOS-next deleted

Removed milestone as this issue was rejected.

Note: See TracTickets for help on using tickets.