Opened 5 years ago

Closed 5 years ago

#386 closed defect (worksforme)

Filter list selection doesn't persist in Firefox on Android

Reported by: drewcam888 Assignee:
Priority: P4 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, saroyanm, trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment ==

Android 4.3.1 stock Samsung Note 2, Firefox 28.0.1, 2.5.1 with easylist.

How to reproduce

  1. I select easylist filter and adblockplus works fine in my Android Firefox browser. If I exit using a quit addon, close using task manager, or restart phone. After reopening the browser there is never a filter list selected. I always have to reselect easylist. Why doesn't it save my selection?

Change History (9)

comment:1 Changed 5 years ago by mapx

  • Cc smultron45@… added
  • Priority changed from Unknown to P2

comment:2 Changed 5 years ago by philll

  • Cc saroyanm added

@saroyanm: FYI

comment:3 Changed 5 years ago by saroyanm

Hmm, Not reproducible on my side, with:
Android: 4.4.2
Firefox 28.0.1
Adblock Plus: 2.5.1 and 26.0.3805

comment:4 Changed 5 years ago by trev

  • Cc trev added
  • Priority changed from P2 to P4

Sounds like filter data isn't being saved, definitely not a common scenario. Not really sure what can be done on Android to find out the cause - even the browser's error console is only accessible via remoting.

Last edited 5 years ago by trev (previous) (diff)

comment:6 in reply to: ↑ 5 Changed 5 years ago by trev

Replying to philll:
Sure, I did - but this would have to be done on the reporter's phone. And using this isn't exactly easy.

comment:7 Changed 5 years ago by trev

  • Summary changed from Adblockplus for Firefox on Android to Filter list selection doesn't persist in Firefox on Android

comment:8 Changed 5 years ago by philll

@drewcam888: Could you please try the latest dev version? I can sort of reproduce something similar with 2.6 but no longer with 2.6.0.3813

comment:9 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

No new information and not reproducible currently, so worksforme. Feel free to reopen if this still happens with the latest dev version.

Note: See TracTickets for help on using tickets.