Opened 4 years ago

Closed 5 months ago

#3874 closed change (rejected)

Click To Flash support

Reported by: Simple Purveyor Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

OS X 10.11.4, Safari 9.1, ABP 1.11, all four standard filters

How to reproduce

Hey guys, glad to see that you finally have a Safari version. I’m psyched to use ABP because it seems to grab all the things that AdBlock apparently can’t see anymore. There’s just one thing that I absolutely need before switching over: Click To Flash compatibility.

I don’t have Flash installed on my computer, but I still use Click To Flash to force tons of websites to feed me a QuickTime video window instead of their terrible HTML5 implementations. YouTube is the big one for this, and it has the added benefit of blocking all in-video ads (because you can’t inject ads into an MP4!).

I spoke directly with AdBlock’s developer in getting CTF compatibility, and he was great about adding it. AdBlock Plus, however, blocks the entire video window and prevents CTF from working.

Not exactly a list of reproducible steps, because it’s ANY website that feeds Flash/HTML 5 video which should be replaced with MP4.

Observed behavior

The entire video DIV is blocked.

Expected behavior

The HTML 5 video DIV is replaced with a native QuickTime video DIV.

Change History (3)

comment:1 Changed 4 years ago by mapx

  • Cc sebastian kzar added

comment:2 Changed 4 years ago by kzar

  • Component changed from Unknown to Platform

Thanks for reporting this.

all four standard filters

Would you mind listing your enabled subscriptions and any custom filters you have?

Not exactly a list of reproducible steps, because it’s ANY website that feeds Flash/HTML 5 video which should be replaced with MP4.

Please could you give reproduction steps for a single video, doesn't matter which one. (As long as it's SFW :p)

comment:3 Changed 5 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

I'm closing all issues related to the legacy Safari extension, as it has been discontinued in favor of an App Extension that doesn't share any code with the old extension.

Note: See TracTickets for help on using tickets.