Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#3877 closed defect (fixed)

Already open options page not updated

Reported by: Ross Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29339116/

Description (last modified by sebastian)

Environment

Reproduced in:
ABP 1.11.0.1590 / Safari 9 / OS X 10.11 (also effects Chrome and Opera)

Could not reproduce in:
ABP 1.11.0.1558 / Safari 9 / OS X 10.11

How to reproduce

  1. Install extension and open ABP options page.
  2. Visit adblockplus.org in a new tab.
  3. Select [ABP Icon] > [Enabled on this page] to disable.
  4. Switch back to already open ABP options page.
  5. Observe whitelist has not been updated with action from Step 3.

Observed behaviour

As of 045c2a14adaa, the already opened options page is not updated with the whitelist entry created by the user actions in Step 3. Refreshing/opening the options page then shows the state correctly. An exception is shown in the options page as the non existing onFilterChange function is called.

This regression was caused by https://hg.adblockplus.org/adblockpluschrome/rev/045c2a14adaa , it looks like we forgot to change calls to the onFilterChange function in two places.

Expected behaviour

The already open options page to stay in sync with current user selections/actions as it used to.

Change History (13)

comment:1 Changed 3 years ago by kzar

  • Cc sebastian kzar added
  • Component changed from Unknown to Platform
  • Milestone Adblock-Plus-for-Chrome-Opera-Safari-next deleted
  • Priority changed from P3 to Unknown

comment:2 Changed 3 years ago by kzar

  • Owner set to kzar
  • Priority changed from Unknown to P2
  • Ready set

Can reproduce as described at HEAD but not at 1.11. Looking into it now.

comment:3 Changed 3 years ago by kzar

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 3 years ago by kzar

  • Description modified (diff)

comment:5 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:6 Changed 3 years ago by sebastian

  • Description modified (diff)

comment:7 Changed 3 years ago by sebastian

  • Description modified (diff)
  • Platform changed from Safari to Unknown / Cross platform

comment:8 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/b98aedabc3ac

comment:9 Changed 3 years ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:10 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 1.11.0.1592
Safari 6.0 / OS X 10.8
Safari 7.1.8 / OS X 10.9.5
Safari 8.0.6 / OS X 10.10.3
Safari 9.1 / OS X 10.11

Last edited 3 years ago by Ross (previous) (diff)

comment:11 Changed 3 years ago by Ross

  • Resolution fixed deleted
  • Status changed from closed to reopened

This actually still occurs. Added filters (via block element in popup) do not get displayed correctly in the options page. This seems to occur more often when the options page is opened right after install, but have also seen it occur when the options page is opened later.

Most of the time it works as expected.

ABP 1.11.0.1593
Safari 6.0 / OS X 10.8
Safari 7.1.8 / OS X 10.9.5
Safari 8.0.6 / OS X 10.10.3

comment:12 Changed 3 years ago by kzar

This sounds more like a new regression caused by the changes in #3870. Could you confirm if the problem is reproducible with 1.11.0.1592?

comment:13 Changed 3 years ago by Ross

  • Resolution set to fixed
  • Status changed from reopened to closed

You're right. This does not occur in 1592. Reported as #3915

ABP 1.11.0.1592
Safari 6.0 / OS X 10.8
Safari 7.1.8 / OS X 10.9.5
Safari 8.0.6 / OS X 10.10.3

Last edited 3 years ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.