Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3879 closed defect (fixed)

CSS property filters ignore third-party stylesheets in Chrome but not in Firefox

Reported by: arthur Assignee: trev
Priority: P1 Milestone:
Module: Core Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29340588/

Description (last modified by trev)

Environment

Firefox 45.0.1 and 46 beta 5
Windows 10
ABP 2.7.2.4157

How to reproduce

  1. Disable all filter lists
  2. Add these 2 custom filters: gala.de##[-abp-properties='cursor: pointer;'] and gala.de##[-abp-properties='margin*: *px;']
  3. Go to gala.de

Observed behaviour

The page will appear blank.

Expected behaviour

The page should show up without issues.

This doesn't happen in Chrome. Note that those 2 filters are currently in EasyList Germany.

Background

Chrome is limited to first-party stylesheets, so unlike Firefox it won't see some of the matching rules.

What to change

Make our Firefox implementation ignore third-party stylesheets for now. We'll likely bring this functionality back later, yet only if some special filter flag is given so that "normal" rule behave the same on Firefox and Chrome.

Change History (9)

comment:1 follow-up: Changed 4 years ago by trev

At least for the margin rule, the problem is the different representation of CSS rules in Firefox and Chrome. While in Chrome you get margin: 0;, in Firefox it will be margin: 0px;.

comment:2 Changed 4 years ago by trev

Looked into differences with cursor: pointer - that's actually a limitation of our Chrome implementation, it simply cannot see some matching CSS rules.

comment:3 in reply to: ↑ 1 Changed 4 years ago by trev

Never mind my comment on `margin: 0;`, both Firefox and Chrome will convert this into margin: 0px;. The problem in both cases is that Chrome doesn't see some CSS rules whereas Firefox can see all of them.

comment:4 Changed 4 years ago by trev

  • Component changed from Adblock-Plus-for-Firefox to Core
  • Description modified (diff)
  • Owner set to trev
  • Priority changed from Unknown to P1
  • Ready set
  • Summary changed from CSS property filters seem to be have differently in Firefox to CSS property filters ignore third-party stylesheets in Chrome but not in Firefox

comment:5 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluscore/rev/82c88024773b

comment:7 Changed 4 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 4 years ago by trev

I filed #3957 for the dependency update.

comment:9 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Working as described / Example page is no longer blank.

ABP 2.7.2.4166
Firefox 44 / 45 / Windows 8

Note: See TracTickets for help on using tickets.