Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3882 closed change (fixed)

Make checkbox labels sensitive on the new option page

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: greiner, athornburgh Blocked By:
Blocking: #2407 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29339231

Description

Background

Currently, clicking the label of any checkbox on the new options page doesn't have any effect. However, users would expect that clicking the label will cause the corresponding checkbox to be toggled, as this is common practice on the web (and for other UIs). Moreover, in particular when using less accurate input devices, it's easier to use checkboxes if the area you can click on is larger (because it includes the label). The old options page accounts for that, so this is a UX regression.

What to change

Toggle the checkboxes on the General tab and the Tweaks section of the Advanced tab when their label is clicked.

Change History (6)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by greiner

  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 4 years ago by greiner

  • Blocking 2407 added

comment:4 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/595580acfe7d

comment:5 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/0ec5d7010cf3

Note: See TracTickets for help on using tickets.