Opened 4 years ago

Closed 4 years ago

#3895 closed defect (fixed)

Artifacts in close icon on dialogs on the new options page

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: #2355 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29339552

Description (last modified by greiner)

How to reproduce

  1. Open the new options page
  2. Click on "add other website language" or "add other filter list"

Observed behavior

There are some artifacts below the close button's icon (i.e. the "x").


That is because the icon is actually just 8x8px, while the CSS sets it's dimensions to 12x12px, causing it to include some pixels of the icon below from the sprite. It also specifies incorrect sprite coordinates since the space between the icons is not part of any of them to avoid bleeding issues.

Expected behavior

The close icon should not include any pixels from other icons.

Attachments (1)

close-button.png (3.7 KB) - added by sebastian 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by sebastian

comment:1 Changed 4 years ago by sebastian

  • Cc greiner added
  • Description modified (diff)

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:4 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:5 Changed 4 years ago by greiner

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:6 Changed 4 years ago by greiner

  • Blocking 2355 added

comment:7 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplusui/rev/ca3ff1974808

comment:8 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.