Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3922 closed defect (fixed)

Adblock Browser crashes caused by blocked popups

Reported by: mario Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.3.1
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

Adblock Browser for iOS 1.3.0 (878)
iOS: 9.*

How to reproduce

  1. Open ABB 1.3.0 and clear the cache by navigating to Settings->Clear Browsing Data->Clear All.
  2. Browse to ​http://thepiratebay.se/
  3. Scroll to the bottom and tap "Return to web version"
  4. Tap the main navigation item "Browse"
  5. Tap the link "Audio" in the content

Observed behaviour

ABB crashes as it tries to suppress a blocked popup.

Expected behaviour

ABB doesn't crash

Additional background

This crash is a regression of #3803 and thus was introduced while updating the Chrome/Safari/Opera extension in ABB from version 1.9.4 to version 1.11.0.1560.

The crash reports clearly indicate that this issue is caused by chrome.tabs.remove while suppressing blocked popups.

Please note that a lot of user feedback indicates crashes during startup. This may be caused by sites which open popups as soon as they are loaded.

Change History (5)

comment:1 Changed 4 years ago by mario

  • Milestone changed from Adblock-Browser-for-iOS-next to Adblock-Browser-for-iOS-1.3.1

comment:2 Changed 4 years ago by mario

We haven't found a way yet to reproduce this error exactly as reported but as the crash reports indicate a problem with ABB closing ad-popups this is a separate way of triggering the same crash:

  1. Open ABB 1.3.0 and clear the cache by navigating to Settings->Clear Browsing Data->Clear All.
  2. Browse to http://thepiratebay.se/
  3. Scroll to the bottom and tap "Return to web version"
  4. Tap the main navigation item "Browse"
  5. Tap the link "Audio" in the content

Result: The app will crash.

comment:3 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 4 years ago by mario

  • Description modified (diff)
  • Ready set
  • Summary changed from Adblock Browser crashes on startup to Adblock Browser crashes caused by blocked popups

comment:5 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Tested with steps provided and across various sites that make use of lots of popups.

ABB for iOS 1.3.1 (April 13th)
iPhone 5S / iOS 9.2

Note: See TracTickets for help on using tickets.