#3924 closed defect (fixed)

Wrong domain entered into whitelist after using back button

Reported by: Ross Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-1.12-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29339714/

Description (last modified by kzar)

Environment

Reproduced in:
ABP 1.11.0.1593
Safari 8.0.6 / OS X 10.10.3 (Also Safari 9.0)

Not reproduced in:
Chrome 43 / Ubuntu 14.04

How to reproduce

  1. Navigate to the devbuilds page (https://adblockplus.org/en/development-builds).
  2. Select the [Older builds] link next for Safari.
  3. Press the Back button in Safari to navigate back to the devbuilds page.
  4. Select [ABP Icon] > [Enabled on this site] to disable on this site.
  5. Select [ABP Icon] > [Options] > [Whitelisted domains].

Observed behaviour

downloads.adblockplus.org was added to the list of whitelisted domains.

Expected behaviour

adblockplus.org should have been added to the list of whitelisted domains instead.

Change History (8)

comment:1 Changed 20 months ago by kzar

  • Cc sebastian kzar added
  • Component changed from Unknown to Platform
  • Platform changed from Unknown / Cross platform to Safari

comment:2 Changed 20 months ago by kzar

  • Description modified (diff)
  • Owner set to kzar
  • Priority changed from Unknown to P2
  • Ready set

Can reproduce as described with Safari 9.0.

comment:3 Changed 20 months ago by kzar

  • Description modified (diff)

comment:4 Changed 20 months ago by kzar

I attempted to pin down when the regression was introduced, but it looks more like a long standing bug, I could reproduce even with 1.9.4. (I stopped trying to bisect at that point!)

I'm not able to reproduce the issue on Chrome either, so this indeed looks like it's Safari specific. Continuing to investigate...

comment:5 Changed 20 months ago by kzar

The content script is simply not being loaded again, which means the loading message is not dispatched and the background page isn't aware that the page has changed. Will experiment with listening for different events (from both background and content script) to see if there's a way we can catch this situation.

comment:6 Changed 20 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Looks like we can listen for the pageshow event, if persisted is true then we know to send the loading message again.

comment:7 Changed 20 months ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockpluschrome/rev/5511dd4badc7

comment:8 Changed 20 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.