Opened 4 years ago

Closed 3 years ago

#3928 closed defect (worksforme)

Press and hold context menu doesn't show up on first try

Reported by: mario Assignee:
Priority: P4 Milestone:
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mario)

Environment

ABB 1.3.1
iOS 9.3.1

How to reproduce

  1. Force-quit ABB and reopen it (in case ABB was already opened)
  2. Browse to any website containing text or images (e.g. http://adblockplus.org/)
  3. Press and hold any content (text or images) on the website to mark it

Observed behaviour

The first time you press and hold any content, the content is marked but no context menu is shown as displayed in this screenshot.

Please note that the second time you press and hold any content, the context menu is shown. It only fails to show said menu the first try.

Expected behaviour

Every time you press and hold any content, the content is marked and the context menu is shown as displayed in this screenshot.

Attachments (2)

image1.PNG (199.0 KB) - added by mario 4 years ago.
image2.PNG (205.2 KB) - added by mario 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by mario

Changed 4 years ago by mario

comment:1 Changed 4 years ago by mario

  • Description modified (diff)
  • Ready set

comment:2 Changed 4 years ago by pavelz

This is reportedly a new (iOS9) malfunction
https://forums.developer.apple.com/thread/23353
Will try to apply some of the magic smoke mentioned there.

comment:3 Changed 4 years ago by mario

  • Priority changed from P3 to P4

comment:5 Changed 3 years ago by mario

  • Resolution set to worksforme
  • Status changed from new to closed

Closed at this has been fixed by Apple in iOS 10

Note: See TracTickets for help on using tickets.