Opened 4 years ago

Closed 2 months ago

#3947 closed defect (invalid)

Excessive block counting on long YouTube videos

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.11.0.1595
Chrome 48
Subscriptions: EasyList English

How to reproduce

  1. Visit this YouTube video: https://www.youtube.com/watch?v=FcTS2Tu64QU
  2. Observe the initial block counter (Seen: 21, 31, 40).
  3. Navigate along the video timeline 5-10 times.
  4. Observe the block counter increases by 10-20-ish (varies) each jump on the timeline.
  5. Observe that after Step 4 (and having jumped near the end of the video), the block counter displays hundreds of blocked adverts.
  6. Repeat the same above using this video: https://www.youtube.com/watch?v=3wmSqpF5ivc
  7. Observe the counter doesn't increase anywhere near the same amount (or sometimes at all) when jumping through the video.

Observed behaviour

Every time certain videos are jumped/scrubbed the block counter is increased by what seems to be an excessive count.

Expected behaviour

The counter to increase with the actual number of blocked adverts.

Change History (2)

comment:1 Changed 4 years ago by Ross

In the first video above, adverts are present in the video timeline (yellow dashes) when ABP is disabled. In the second there are no "in-timeline" adverts. That explains some of the difference in count between the two, but are there really 10-20+ adverts being blocked every jump in the first video? Is it counting all the adverts in the timeline each jump?

I noticed this after noticing #442. The explanation given in that ticket makes sense and could apply here. Just the count seems excessive. (I still need to/should try the same with an older build).

comment:2 Changed 2 months ago by greiner

  • Cc greiner added
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket because I agree that this appears to be due to (a) the counter representing the number of blocked requests, not the number of blocked ads and (b) YouTube not causing to reset due to the way it implements page navigation without any actual page loads.

Note: See TracTickets for help on using tickets.