Opened 3 years ago

Closed 5 weeks ago

#3951 closed defect (invalid)

Duplicate filters can sometimes be added via Block element

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: kzar, sebastian, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.11.0.1595
Chrome 32 / 42 / 48
Windows 8

How to reproduce

  1. Navigate to the dev build page: https://adblockplus.org/en/development-builds
  2. Install the latest ABP Chrome build.
  3. Open the ABP options page after install.
  4. Switch back to the dev build page and refresh it.
  5. Select [ABP Icon] > [Block element] and select the ABP icon in the top left corner of the page.
  6. Observe two filters are suggested (#logo and .sprite). Add them.
  7. Select [ABP Icon] > [Block element] and select anything else on the page.
  8. Manually edit the suggested filter to "adblockplus.org##.sprite" and add it.
  9. Switch back to the ABP options page > Custom filters.
  10. Observe the .sprite filter has been added twice / duplicated.

Observed behaviour

Sometimes, but not all the time (reproduced 3/8 attempts), it's possible to add duplicate custom filters via the Block element functionality. Normally duplicates are ignored, both when adding a filter via Block element and in the options page/tab itself.

Expected behaviour

Attempts to add duplicate filters to be ignored.

Attachments (1)

Duplicates.png (156.6 KB) - added by Ross 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Ross

comment:1 Changed 3 years ago by Ross

I noticed this while testing #3830, although not sure if related.

comment:2 Changed 3 years ago by kzar

  • Cc sebastian added
  • Component changed from Core to Platform

comment:3 Changed 3 years ago by sebastian

  • Cc greiner added
  • Component changed from Platform to User-Interface

Moving to User-Interface, as that is where the responsible message responder is.

comment:4 Changed 3 years ago by greiner

  • Priority changed from Unknown to P3
  • Ready set

comment:5 Changed 5 weeks ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket because a lot of the code related to UI mentioned here has changed since. Please create a GitLab issue, if you can still reproduce this issue using the latest builds.

Note: See TracTickets for help on using tickets.