Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#3954 closed defect (fixed)

Websites are rendered incorrectly and assets aren't loaded as soon as a popup/new tab is triggered

Reported by: mario Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.3.2
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: pavelz Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by mario)

Environment

ABB 1.3.0 & ABB 1.3.1
iOS 9.3.1
Device-independent

How to reproduce

  1. Install ABB 1.3.1
  2. Open ABB
  3. Browse to http://news.google.com/
  4. Tap one of the linked articles (it will open in a new tab)
  5. Keep browsing different websites (e.g. http://zeit.de/)

Observed behaviour

All of the visited websites (after invoking a new tab via http://news.google.com/) are broken as shown in this screenshot or in this screenshot:

  1. The websites seem to be loaded multiple times (nested into itself)
  2. Assets don't seem to be loaded (Javascript as well as CSS)
  3. Images are only partially loaded

Expected behaviour

Websites are displayed correctly.

Additional information

http://news.google.com/ triggers the malfunction by invoking a new tab. Every other website invoking popups or new tabs (e.g. http://digg.com/) cause ABB to malfunction as well.
The problem can be temporarily "fixed" by force-quitting ABB and opening it again.

Attachments (2)

image1-2.PNG (67.0 KB) - added by mario 3 years ago.
image1-3.PNG (63.2 KB) - added by mario 3 years ago.

Download all attachments as: .zip

Change History (16)

Changed 3 years ago by mario

comment:1 Changed 3 years ago by mario

  • Description modified (diff)

comment:2 Changed 3 years ago by mario

  • Priority changed from P1 to P3

The method stated in the description has not proven to be a valid way of reproducing the issue. Reducing the priority as only two users so far seem to be affected. We will update the issue as soon as there's a viable way of reproducing said bug.

comment:3 Changed 3 years ago by mario

  • Ready unset

comment:4 Changed 3 years ago by mario

  • Description modified (diff)
  • Summary changed from Large images are displayed incorrectly to Website assets are not loaded correctly after updating to most recent version

comment:5 Changed 3 years ago by mario

  • Description modified (diff)

comment:6 Changed 3 years ago by mario

  • Description modified (diff)

comment:7 Changed 3 years ago by mario

  • Description modified (diff)
  • Summary changed from Website assets are not loaded correctly after updating to most recent version to Specific websites are rendered incorrectly and assets aren't loaded

We've discovered this problem to not only appear after updating, but also after while using it in general. I've adjusted the issue to reflect that fact.

Changed 3 years ago by mario

comment:8 Changed 3 years ago by mario

  • Description modified (diff)
  • Priority changed from P3 to P1
  • Ready set

comment:9 Changed 3 years ago by mario

  • Description modified (diff)

comment:10 Changed 3 years ago by mario

  • Description modified (diff)
  • Summary changed from Specific websites are rendered incorrectly and assets aren't loaded to Websites are rendered incorrectly and assets aren't loaded as soon as a popup/new tab is triggered

We've discovered that the issue is triggered by websites which open either popups or new tabs. Adjusted the description.

comment:12 Changed 3 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 3 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.3.2

comment:14 Changed 3 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • Pages opened in the pop-up window that is created from news.google.com now load correctly.

ABB 1.3.2
iPHone 6 Plus
iOS 9.3.1

Note: See TracTickets for help on using tickets.