Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3958 closed defect (fixed)

Firefox needs to be restarted to block ads when updating to a new dev build

Reported by: arthur Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.7.3-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: #3499 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29340653/

Description (last modified by trev)

Environment

Windows 10 Pro
Firefox 45.0.2
Adblock Plus 2.7.2.4161

How to reproduce

  1. Go into the Add-ons Manager of Firefox and force an update so the dev build will be udpated to 2.7.2.4162 (or newer)
  2. Go to a website that usually has ads

Observed behaviour

No ads seem to be blocked. Also, there are no blockable items in the blockable items list of ABP. Once you restart Firefox, ads are being blocked again.

Expected behaviour

Ads should be blocked without a restart.

Background

It seems that in the upgrade scenario the new child/bootstrap is running earlier than the old one receives the shutdown message, at least in the chrome process. Consequently, the new content policy attempts to register before the old one has been removed - and fails. The important timing change was introduced in #3499 apparently, initializing child/bootstrap no longer requires exchanging messages so that it's happening synchronously in the chrome process.

All Firefox versions are affected regardless of whether E10S is switched on - with E10S this problem is masked however because the failure only affects the chrome process, web pages load in the content process however.

What to change

Add an artificial message roundtrip before initializing process scripts, in order to give the old version enough time to shut down.

Change History (8)

comment:1 Changed 4 years ago by trev

  • Priority changed from Unknown to P1
  • Ready set

Yes, I've seen that issue myself and wanted to investigate tomorrow, thanks for filing.

comment:2 Changed 4 years ago by trev

  • Blocking 3499 added
  • Description modified (diff)

comment:3 Changed 4 years ago by trev

  • Description modified (diff)
  • Owner set to trev

comment:4 Changed 4 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 4 years ago by trev

  • Description modified (diff)

comment:6 Changed 4 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/adblockplus/rev/a883df5b0107

comment:7 Changed 4 years ago by trev

  • Milestone set to Adblock-Plus-2.7.3-for-Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

ABP 2.7.2.4165
Firefox 44 / 45 / Windows 8
Firefox 44 / Ubuntu 14.04

Note: See TracTickets for help on using tickets.