Opened 4 years ago

Closed 4 years ago

#3973 closed defect (rejected)

finalUrl is often about:blank

Reported by: sergz Assignee:
Priority: Unknown Milestone:
Module: Extensions-for-Adblock-Plus Keywords: abpcrawler
Cc: trev, tschuster Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox 45

How to reproduce

  1. Run crawler with several web sites
  2. find that some (not all) json files contain "finalUrl": "about:blank"

Expected behaviour

finalUrl property should contain an actual URL.

Change History (2)

comment:1 Changed 4 years ago by trev

I think the problem is not the finalUrl field, rather that no error was logged. That's host names that failed to resolve or hosts that didn't accept connections, we should have logged the channel status here.

comment:2 Changed 4 years ago by sergz

  • Resolution set to rejected
  • Status changed from new to closed

Sorry, it was a local bug.

Note: See TracTickets for help on using tickets.