Opened 5 years ago

Closed 5 years ago

#398 closed defect (incomplete)

Google Search and Maps working properly when ABP activated

Reported by: dee7kay Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS: Mac OS X 10.8.5
Browser: Firefox 29.0
ABP 2.5.1
Filter lists: EasyList germany+EasyList AND Malware Domains

I observe a strange behaviour of Google services when ABP is activated. Everything works fine when it's deactivated. Note: I tried to deactivate all other addons and then look what happens, but obvioulsy this only happens when ABP is activated no matter what the other addons are set.

The problem is as follows:
When ABP is activated on the google web search start page (www.google.com) the Google logo is not loading and I don't get any search suggestions (I activated them in my settings) (see picture #1) The search itself is working (upon hitting enter) and the buttons at the top right of the search results page for private search results are working but the little logos inside of them are gone. The button with the gear wheel is not working when clicking upon and the gear wheel does not appear. (see picture #2)

The second Google service where I noticed strange behaviour is Google Maps (maps.google.com). When loading the website I only get a blank (beige) page where a map should appear. (see picture #3) The search box is not working, neither do I get any suggestions for places, nor do I get a result when hitting enter nor when clicking on the search icon (magnifying glass). None of the other buttons at the bottom left (for a satellite picture) or the bottom right (for zooming, street view etc.)

At both websites the two buttons at the top right (the grid for the different Google services and the button with my own googlemail address / account) seem to work properly as far as I can see.

Attachments (3)

Bildschirmfoto 2014-04-28 um 22.05.19.png (47.3 KB) - added by dee7kay 5 years ago.
Google start page
Bildschirmfoto 2014-04-28 um 22.05.44.png (73.8 KB) - added by dee7kay 5 years ago.
Google search results page
Bildschirmfoto 2014-04-28 um 22.21.55.png (157.2 KB) - added by dee7kay 5 years ago.
Google maps start page

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by dee7kay

Google start page

Changed 5 years ago by dee7kay

Google search results page

Changed 5 years ago by dee7kay

Google maps start page

comment:1 Changed 5 years ago by dee7kay

I forgot something: When searching for pictures with Google, clicking on the results (thumbnails) has no effect, the standard page with the white "toolbar" on the right does not open. But when I open it in a new tab (with Command+click on my Mac) the expected page opens.

The only other Google service I use regularly is Youtube but there everything works fine as expected. I can't say anything about other Google services since I don't use them and have no experience

comment:2 Changed 5 years ago by dee7kay

Note: When speaking of deactivating the addon I meant that I went to the Firefox addon page about:addons and clicked on deactivate. I just noticed that using the ABP logo and clicking on "deactivate everywhere" or "deactivate at google.de" seems to have the same effect.

comment:3 Changed 5 years ago by arthur

  • Resolution set to invalid
  • Status changed from new to closed

Updating "Malware Domains" should resolve this: https://adblockplus.org/en/faq_basics#update-filterlists

Note: See TracTickets for help on using tickets.