Opened 4 years ago

Closed 3 years ago

#3980 closed defect (worksforme)

ABB crashes when visiting digg.com

Reported by: scheer Assignee:
Priority: P4 Milestone:
Module: Adblock-Browser-for-iOS Keywords:
Cc: mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: no
Review URL(s):

Description (last modified by mario)

When the user visits digg.com, ABB crashes. No crash report is asked for, so this could be a memory issue. Please find attached the Jetsam report. Sometimes the user can load the page and then wait 1-2 seconds before the crash occurs.

Currently, this only occurs on the device listed below. On other devices, it can occur only once or not at all.

*Please note, this also occurs on Opera for iOS which suggests that this is a general Problem with the UIWebView component.

Environment

ABB 1.3.2
ABB 1.3.1
ABB 1.3.0
iPhone 6 Plus
iOS 9.3.1

*Also occurs on Opera for iOS

How to reproduce

  1. Install ABB 1.3.2
  2. Open www.digg.com

Observed behaviour

When visiting digg.com, ABB crashes.

Expected behaviour

When visiting digg.com, ABB should not crash.

Attachments (1)

JetsamCrash2.txt (32.2 KB) - added by scheer 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by scheer

comment:1 Changed 4 years ago by mario

  • Ready set

comment:2 Changed 4 years ago by scheer

  • Description modified (diff)

comment:3 Changed 4 years ago by scheer

  • Description modified (diff)

comment:4 Changed 4 years ago by mario

  • Description modified (diff)
  • Milestone Adblock-Browser-for-iOS-1.3.2 deleted
  • Priority changed from Unknown to P4

Caused by UIWebView and thus only indirectly fixable. Lowered the priority.

comment:5 Changed 3 years ago by pavelz

  • Cc mario added

Can't reproduce on iPhone6/iOS10/ABB 1.5.1
CC @mario

comment:6 Changed 3 years ago by mario

@scheer, can you confirm, that this is fixed in iOS 10?
Unfortunately I cannot find any change logs/reports regarding iOS 10 fixing memory issues in UIWebView.

comment:7 Changed 3 years ago by scheer

@mario - I was not able to reproduce this at all in the following setups:

iPhone 6s
iOS 10.0.2
ABB 1.4.0-QA (1032)

iPhone 6s
iOS 10.0.2
ABB 1.5.1 (1137)

iPhone 6s Plus
iOS 9.3.4
ABB 1.4.0-QA (1032)

iPhone 6s Plus
iOS 9.3.4
ABB 1.5.1 (1137)

*Note that ABB 1.4.0-QA (1032) was the oldest version I was able to check this against as the others had expired.

comment:8 Changed 3 years ago by mario

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.