Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3983 closed defect (fixed)

[ios8] ABB wipes data after update

Reported by: mario Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.3.2
Module: Adblock-Browser-for-iOS Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

Description

This issue seems to be limited to iOS 8.4.1. I couldn't reproduce it on any newer version.

Environment

iOS 8.4.1
iPhone 5s
ABB 1.2.1 to 1.3.1

How to reproduce

  1. Install ABB 1.2.1
  2. Open ABB and browse a few websites to gather history data
  3. Go to the App Store and install ABB 1.3.1
  4. Open ABB

Observed behaviour

A error message is shown saying "User data migration failed: Can't find model for source store. Data will be cleared." and all custom data (history, bookmarks, settings) is deleted.

Expected behaviour

No error message is shown and no custom data is deleted.

Change History (6)

comment:1 Changed 4 years ago by pavelz

  • Summary changed from ABB wipes data after update to [ios8] ABB wipes data after update

comment:2 Changed 4 years ago by pavelz

The cause is ios8 incapable of migrating a database consisting of (and merged from) two separate data models
https://github.com/magicalpanda/MagicalRecord/issues/890

comment:4 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by Shikitita

  • Verified working set

comment:6 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.3.2
Note: See TracTickets for help on using tickets.