Opened 3 years ago

Closed 2 years ago

#3986 closed defect (worksforme)

Thunderbird warining and exception during static website generation

Reported by: saroyanm Assignee:
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: sebastian, juliandoucette, jsonesen, kvas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Environment

Python 2.7

How to reproduce

  1. clone web.adblockplus.org repository
  2. Generate static content using CMS
  3. Observe

Observed behaviour

WARNING:root:Failed to get thunderbird versions, falling back to cached versions
Traceback (most recent call last):

File "latest-content!globals/get_browser_versions.py", line 196, in get_browser_versions
File "latest-content!globals/get_browser_versions.py", line 71, in <lambda>
File "latest-content!globals/get_browser_versions.py", line 66, in get_mozilla_versions
File "latest-content!globals/get_browser_versions.py", line 51, in get_mozilla_version

Exception: No updates for Thunderbird in nightly channel

Expected behaviour

No Warning is show while this issue persist for a month.

Notes

Current B2G updates are not available:
https://aus4.mozilla.org/update/3/Thunderbird/31.0/-/WINNT_x86-msvc/en-US/nightly/-/default/default/update.xml?force=1
https://aus2-community.mozilla.org/update/3/SeaMonkey/2.32/-/Linux_x86-gcc3/en-US/aurora/-/default/default/update.xml?force=1

Change History (6)

comment:1 Changed 3 years ago by saroyanm

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 3 years ago by saroyanm

  • Cc sebastian juliandoucette added

@Sebastian: do you know if nightly for Thunderbird and aurora for SeaMonkey exists ?
I'm not sure if this issue is Mozilla related, or should we remove check for this channels ?

comment:3 Changed 2 years ago by juliandoucette

  • Cc jsonesen kvas added

@jsonesen @kvas

You guys could take this one.

comment:4 Changed 2 years ago by jsonesen

Locally, I am not receiving this error. When you say "generate static content" what terminal commands are you using?

comment:5 Changed 2 years ago by kvas

Works for me also without any errors. I suppose this issue is triggered by the absense of Thunderbird updates in a nightly channel, so it's tricky to reproduce.

It seems like some silent failure support is already implemented but only for one day (see #2722). Perhaps the trick would be to change the delay there to 30 days instead of one.

comment:6 Changed 2 years ago by saroyanm

  • Resolution set to worksforme
  • Status changed from new to closed

This might be not reproducible because of -> #4087 fix.
I'll mark this as worksforme for now.

Note: See TracTickets for help on using tickets.